For any production inquiries, TrueCommerce Home's Support team can be reached at: SD-Support@truecommerce.com or 858-634-5055
Posted Apr 29, 2026 - 21:57 EDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 29, 2026 - 21:00 EDT
Update
We will be undergoing scheduled maintenance during this time.
Posted Apr 29, 2026 - 08:34 EDT
Scheduled
Maintenance for TrueCommerce Home (ecUtopia) has been scheduled during the following window on Wednesday April 29, 2026:
Begin at: 9:00 p.m. ET End by: 10:00 p.m ET
During this one-hour maintenance period, webservice (API) connections established with TrueCommerce Home will experience an interruption and access to TrueCommerce Home portal will not be available. Transmissions sent to TrueCommerce Home via direct connections, such as AS2 and TrueCommerce’s hosted SFTP and FTP, will not experience a disruption; however, there could be a residual delay in processing.
We apologize for any inconvenience this may cause.
To stay informed of additional maintenance announcements and see the current status of our systems, register for status page updates by navigating to https://status.truecommerce.com and selecting “Subscribe to Updates”.
Posted Apr 28, 2026 - 12:41 EDT
This scheduled maintenance affected: Platforms (TrueCommerce Home).