B2BGateway Email Server IP Blocked

Incident Report for TrueCommerce

Resolved

Proofpoint has removed the block on our IP 74.118.73.43.
Posted May 05, 2026 - 13:12 EDT

Identified

Email Delivery Advisory (Proofpoint Customers Only)
Proofpoint has temporarily blocked a B2BGateway mail server IP (74.118.73.43) due to spam filtering rules. This impacts only B2BGateway customers using Proofpoint. The IP is not listed on other major blocklists.
We have opened a request with Proofpoint to remove the block and are actively monitoring. Customers may also submit a request with Proofpoint to help expedite resolution:
https://www.proofpoint.com/us/ipcheck
Please note, all Support tickets or New Partner Implementation notes are still available to view and respond to on the B2BGateway Portal.
Posted May 04, 2026 - 11:11 EDT
This incident affected: Trading Network (TrueCommerce B2B Trading Network) and Platforms (TrueCommerce B2B Warehouse Support Site, TrueCommerce B2B Integrator).