TrueCommerce Home - Transaction latency

Incident Report for TrueCommerce

Resolved

This incident has been resolved.
Posted Feb 27, 2026 - 20:17 EST

Monitoring

A fix has been implemented, and the team is actively monitoring the situation. Transaction processing has returned to normal operating times.
Posted Feb 27, 2026 - 20:16 EST

Update

We are continue to investigate the incident. Transactions are processing but delayed.
Posted Feb 27, 2026 - 19:26 EST

Investigating

We are currently experiencing delays in transaction processing for TrueCommerce Home. The team is actively reviewing and will provide updates as we work to restore to standard processing times.
Posted Feb 27, 2026 - 18:50 EST
This incident affected: Platforms (TrueCommerce Home).