Pack and Ship - Shipment Screen not loading
Incident Report for TrueCommerce
Resolved
This incident has been resolved.
Posted Sep 03, 2024 - 09:16 EDT
Monitoring
The issue is resolved and the team is monitoring.
Posted Sep 03, 2024 - 08:59 EDT
Investigating
We're currently experiencing issues with the shipment screen not loading for Pack and Ship. The team is actively investigating.
Posted Sep 03, 2024 - 08:40 EDT
This incident affected: Foundry Applications (Pack & Ship).