TCNet SFTP Connectivity

Incident Report for TrueCommerce

Resolved

The issue has been resolved. Transaction processing has been restored for SFTP connections. Other connections like AS2 were not impacted during this incident.
Posted Sep 04, 2025 - 21:49 EDT

Monitoring

The issue has been resolved. The team is actively monitoring.
Posted Sep 04, 2025 - 21:23 EDT

Update

We are continuing to investigate this issue.
Posted Sep 04, 2025 - 20:41 EDT

Investigating

We are currently experiencing connectivity issues with our SFTP.truecommerce.com connection. This is impacting both integration SFTP connectivity as well as trading partner connectivity. The team is actively working to restore connectivity.
Posted Sep 04, 2025 - 20:40 EDT
This incident affected: Foundry Applications (Transaction Manager) and Trading Network (TrueCommerce Internal FTP).